Lucene search

K
mageiaGentoo FoundationMGASA-2021-0588
HistoryDec 29, 2021 - 10:12 p.m.

Updated kernel packages fix security vulnerabilities

2021-12-2922:12:56
Gentoo Foundation
advisories.mageia.org
29

7.8 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

4.7 Medium

CVSS2

Access Vector

Access Complexity

Authentication

NONE

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

COMPLETE

AV:L/AC:M/Au:N/C:N/I:N/A:C

0.001 Low

EPSS

Percentile

32.1%

This kernel update is based on upstream 5.15.11 and fixes at least the following security issues: netdevsim: Zero-initialize memory for new map’s value in function nsim_bpf_map_alloc (CVE-2021-4135). Potentially malicious XEN PV backends can cause guest DoS due to unhardened frontends in the guests, even though this ought to have been prevented by containing them within a driver domain. This update fixes the issue tracked as XSA-391: blkfront (CVE-2021-28711), netfront (CVE-2021-28712), hvc_xen (CVE-2021-28713). The Linux kernel’s xen-netback backend driver can be forced by guests to queue arbitrary amounts of network data, finally causing an out of memory situation in the domain the backend is running in (usually dom0). This update fixes the issues tracked as XSA-392 (CVE-2021-28714, CVE-2021-28715). In __f2fs_setxattr in fs/f2fs/xattr.c in the Linux kernel through 5.15.11, there is an out-of-bounds memory access when an inode has an invalid last xattr entry (CVE-2021-45469). rds: memory leak in __rds_conn_create() (CVE-2021-45480). In addition to the upstream changes, we also have added the following fixes: - ALSA: hda/hdmi: Disable silent stream on GLK - arm64: vdso32: require CROSS_COMPILE_COMPAT for gcc+bfd - ext4: check for inconsistent extents between index and leaf block - ext4: check for out-of-order index extents in ext4_valid_extent_entries() - ext4: prevent partial update of the extent blocks - HID: intel-ish-hid: ipc: Specify no cache snooping on TGL and ADL - HID: potential dereference of null pointer - iwlwifi: mvm: Increase the scan timeout guard to 30 seconds - KVM: VMX: clear vmx_x86_ops.sync_pir_to_irr if APICv is disabled - net: amd-xgbe: Add Support for Yellow Carp Ethernet device - net: usb: lan78xx: add Allied Telesis AT29M2-AF - netfs: fix parameter of cleanup() - NFSD: Fix READDIR buffer overflow - PM: sleep: Fix error handling in dpm_prepare() - restored legacy NTLM support in cifs (mga#29641) - revert: “rtw88: 8821c: disable the ASPM of RTL8821CE” - rtw88: add quirk to disable pci caps on HP 250 G7 Notebook PC - rtw88: Disable PCIe ASPM while doing NAPI poll on 8821CE - rtw88: don’t check CRC of VHT-SIG-B in 802.11ac signal - rtw88: 8822c: update rx settings to prevent potential hw deadlock - rtw89: 8852a: correct bit definition of dfs_en For other upstream fixes, see the referenced changelogs.

7.8 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

4.7 Medium

CVSS2

Access Vector

Access Complexity

Authentication

NONE

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

COMPLETE

AV:L/AC:M/Au:N/C:N/I:N/A:C

0.001 Low

EPSS

Percentile

32.1%