logo
DATABASE RESOURCES PRICING ABOUT US

Updated nvidia packages fix security vulnerabilities

Description

Updated nvidia304 and nvidia-current drivers fixes security issues: The NVIDIA Linux Discrete GPU drivers before R304.125, R331.x before R331.113, R340.x before R340.65, R343.x before R343.36, and R346.x before R346.22, Linux for Tegra (L4T) driver before R21.2, and Chrome OS driver before R40 allows remote attackers to cause a denial of service (segmentation fault and X server crash) or possibly execute arbitrary code via a crafted GLX indirect rendering protocol request (CVE-2014-8093, CVE-2014-8098, CVE-2014-8298). Note, the nvidia173 173.14.39 driver in Mageia 4 is also vulnerable to this issue, but as it has reached EOL upstream it wont get any fixes for this. For nvidia-cuda-toolkit, it's safe to use with the fixed nvidia304 and nvidia-current drivers released as part of this update.


Affected Package


OS OS Version Package Name Package Version
Mageia 4 kmod-nvidia-current 331.113-1
Mageia 4 nvidia-current 331.113-1
Mageia 4 kmod-nvidia304 304.125-1
Mageia 4 nvidia304 304.125-1

Related