OpenAM <= 16.0.5 - Pre-Auth RCE via jato.clientSession Deserialization Detection
10
#!/usr/bin/env python3
# -*- coding: utf-8 -*-
"""Open Access Management (OpenAM) is an access management solution."""
from kittysploit import *
from lib.protocols.http.http_client import Http_client
class Module(Scanner, Http_client):
__info__ = {
'name': 'OpenAM <= 16.0.5 - Pre-Auth RCE via jato.clientSession Deserialization Detection',
'description': 'Open Access Management (OpenAM) is an access management solution. Prior to 16.0.6, OpenIdentityPlatform OpenAM is vulnerable to pre-authentication Remote Code Execution (RCE) via unsafe Java deserialization of the jato.clientSession HTTP parameter. This bypasses the WhitelistObjectInputStream mitigation that was applied to the jato.pageSession parameter after CVE-2021-35464. This vulnerability is fixed in 16.0.6.',
'author': ['KittySploit Team'],
'severity': 'critical',
'tags': ['web', 'scanner', 'cve', 'cve2026', 'openam', 'deserialization', 'rce', 'jato', 'oast', 'oob'],
'agent': {
'risk': 'active',
'effects': ['network_probe'],
'expected_requests': 1,
'reversible': True,
'approval_required': False,
'produces': ['tech_hints', 'risk_signals', 'endpoints'],
'cost': 1.0,
'noise': 0.3,
'value': 1.0,
'requires': {
'min_endpoints': 0,
'min_params': 0,
'tech_hints_any': [],
'tech_hints_all': [],
'specializations_any': [],
'risk_signals_any': [],
'auth_session': False,
'capabilities_any': [],
'capabilities_all': [],
'confidence_min': {},
'confidence_min_any': {},
'endpoint_pattern_any': [],
'param_any': [],
'api_surface_ready': False,
},
'chain': {
'produces_capabilities': [
{
'capability': 'admin_surface',
'from_detail': '',
},
],
'consumes_capabilities': [],
'option_bindings': {},
'suggested_followups': [
'exploits/multi/http/openam_cve_2026_33439_rce',
],
},
},
'references': [
'https://www.hacktron.ai/blog/openam-deserialization-pre-auth-rce',
'https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-2cqq-rpvq-g5qj',
],
'cve': 'CVE-2026-33439',
}
def run(self):
r = self.http_request(method="GET", path='/openam/ui/PWResetUserValidation', allow_redirects=False)
if not r or r.status_code != 200:
return False
body = r.text or ""
body_all = ('OpenAM', 'tfUserAttr',)
if (all(m in body for m in body_all)):
self.set_info(
severity='critical',
reason="OpenAM <= 16.0.5 - Pre-Auth RCE via jato.clientSession Deserialization detected",
path='/openam/ui/PWResetUserValidation',
)
return True
return False
Data
Build on a solid foundation with Vulners data
We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data
Api
Power your application with Vulners API
The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access
App
Assess and manage vulnerabilities with Vulners tools
Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation
05 Oct 2026 14:20Current
6.2Medium risk
Vulners AI Score6.2
CVSS 3.19.8
CVSS 49.3
EPSS0.09333
SSVC