Lucene search

K
kasperskyKaspersky LabKLA52367
HistoryAug 21, 2023 - 12:00 a.m.

KLA52367 Multiple vulnerabilities in Microsoft Browser

2023-08-2100:00:00
Kaspersky Lab
threats.kaspersky.com
15
microsoft browser
vulnerabilities
high severity
public exploits
microsoft edge

CVSS3

8.8

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

AI Score

10

Confidence

High

EPSS

0.003

Percentile

69.1%

Multiple vulnerabilities were found in Microsoft Browser. Malicious users can exploit these vulnerabilities to cause denial of service, bypass security restrictions, obtain sensitive information, spoof user interface, execute arbitrary code, gain privileges.

Below is a complete list of vulnerabilities:

  1. Validation of untrusted input vulnerability in XML can be exploited to cause denial of service.
  2. Implementation vulnerability in Fullscreen can be exploited to cause denial of service.
  3. An information disclosure vulnerability in Microsoft Edge (Chromium-based) can be exploited remotely to obtain sensitive information.
  4. Heap buffer overflow vulnerability in Mojom IDL can be exploited to cause denial of service.
  5. Implementation vulnerability in WebShare can be exploited to cause denial of service.
  6. Use after free vulnerability in Device Trust Connectors can be exploited to cause denial of service or execute arbitrary code.
  7. Policy enforcement vulnerability in Extensions API can be exploited to cause denial of service.
  8. Use after free vulnerability in Offline can be exploited to cause denial of service or execute arbitrary code.
  9. Use after free vulnerability in Extensions can be exploited to cause denial of service or execute arbitrary code.
  10. Use after free vulnerability in DNS can be exploited to cause denial of service or execute arbitrary code.
  11. Implementation vulnerability in App Launcher can be exploited to cause denial of service.
  12. Heap buffer overflow vulnerability in Skia can be exploited to cause denial of service.
  13. Heap buffer overflow vulnerability in ANGLE can be exploited to cause denial of service.
  14. Use after free vulnerability in Network can be exploited to cause denial of service or execute arbitrary code.
  15. Type confusion vulnerability in V8 can be exploited to cause denial of service.
  16. Implementation vulnerability in Autofill can be exploited to cause denial of service.
  17. An elevation of privilege vulnerability in Microsoft Edge (Chromium-based) can be exploited remotely to gain privileges.
  18. Use after free vulnerability in Audio can be exploited to cause denial of service or execute arbitrary code.
  19. Implementation vulnerability in Permission Prompts can be exploited to cause denial of service.
  20. Out of bounds memory access vulnerability in V8 can be exploited to cause denial of service.
  21. Implementation vulnerability in Color can be exploited to cause denial of service.

Original advisories

CVE-2023-4357

CVE-2023-4365

CVE-2023-38158

CVE-2023-4362

CVE-2023-4363

CVE-2023-4349

CVE-2023-4367

CVE-2023-2312

CVE-2023-4368

CVE-2023-4366

CVE-2023-4358

CVE-2023-4359

CVE-2023-4354

CVE-2023-4353

CVE-2023-4351

CVE-2023-4352

CVE-2023-4361

CVE-2023-36787

CVE-2023-4356

CVE-2023-4364

CVE-2023-4355

CVE-2023-4360

CVE-2023-4350

Exploitation

Public exploits exist for this vulnerability.

Malware exists for this vulnerability. Usually such malware is classified as Exploit. More details.

Related products

Microsoft-Edge

CVE list

CVE-2023-4365 warning

CVE-2023-4359 high

CVE-2023-4363 warning

CVE-2023-4367 high

CVE-2023-4354 critical

CVE-2023-4356 critical

CVE-2023-4357 critical

CVE-2023-4362 critical

CVE-2023-4352 critical

CVE-2023-4364 warning

CVE-2023-4368 critical

CVE-2023-4361 high

CVE-2023-4358 critical

CVE-2023-4351 critical

CVE-2023-4350 high

CVE-2023-4360 warning

CVE-2023-2312 critical

CVE-2023-4366 critical

CVE-2023-4353 critical

CVE-2023-4355 critical

CVE-2023-4349 critical

CVE-2023-36787 critical

CVE-2023-38158 warning

KB list

Solution

Install necessary updates from the Settings and more menu, that are listed in your About Microsoft Edge page (Microsoft Edge About page usually can be accessed from the Help and feedback option)

Microsoft Edge update settings

Impacts

  • ACE

Arbitrary code execution. Exploitation of vulnerabilities with this impact can lead to executing by abuser any code or commands at vulnerable machine or process.

  • OSI

Obtain sensitive information. Exploitation of vulnerabilities with this impact can lead to capturing by abuser information, critical for user or system.

  • DoS

Denial of service. Exploitation of vulnerabilities with this impact can lead to loss of system availability or critical functional fault.

  • SB

Security bypass. Exploitation of vulnerabilities with this impact can lead to performing actions restricted by current security settings.

  • PE

Privilege escalation. Exploitation of vulnerabilities with this impact can lead to performing by abuser actions, which are normally disallowed for current role.

  • SUI

Spoof user interface. Exploitation of vulnerabilities with this impact can lead to changes in user interface to beguile user into inaccurate behavior.

Affected Products

  • Microsoft Edge (Chromium-based)

References

CVSS3

8.8

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

AI Score

10

Confidence

High

EPSS

0.003

Percentile

69.1%