Lucene search

K
kasperskyKaspersky LabKLA20013
HistoryOct 18, 2022 - 12:00 a.m.

KLA20013 Multiple vulnerabilities in Oracle Java SE and GraalVM

2022-10-1800:00:00
Kaspersky Lab
threats.kaspersky.com
137

5.3 Medium

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

LOW

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

7.3 High

AI Score

Confidence

High

0.002 Low

EPSS

Percentile

59.6%

Multiple vulnerabilities were found in Oracle Java SE and GraalVM. Malicious users can exploit these vulnerabilities to execute arbitrary code, gain privileges, cause denial of service.

Below is a complete list of vulnerabilities:

  1. An elevation of privilege vulnerability in Networking can be exploited remotely to gain privileges and execute arbitrary code.
  2. A denial of service vulnerability in Lightweight HTTP Server can be exploited to cause denial of service and execute arbitrary code.
  3. An elevation of privilege vulnerability in JNDI can be exploited remotely to gain privileges and execute arbitrary code.
  4. An elevation of privilege vulnerability in JGSS can be exploited remotely to gain privileges and execute arbitrary code.
  5. An elevation of privilege vulnerability in Security can be exploited remotely to gain privileges and execute arbitrary code.
  6. A denial of service vulnerability in Security can be exploited to cause denial of service and execute arbitrary code.

Original advisories

Oracle Critical Patch Update Advisory – October 2022

Related products

Oracle-Java-JRE-1.7.x

Oracle-Java-JRE-1.8.x

CVE list

CVE-2022-39399 warning

CVE-2022-21628 high

CVE-2022-21624 warning

CVE-2022-21618 high

CVE-2022-21619 warning

CVE-2022-21626 high

Solution

Update to the latest version

Download Java

Impacts

  • ACE

Arbitrary code execution. Exploitation of vulnerabilities with this impact can lead to executing by abuser any code or commands at vulnerable machine or process.

  • DoS

Denial of service. Exploitation of vulnerabilities with this impact can lead to loss of system availability or critical functional fault.

  • SB

Security bypass. Exploitation of vulnerabilities with this impact can lead to performing actions restricted by current security settings.

  • PE

Privilege escalation. Exploitation of vulnerabilities with this impact can lead to performing by abuser actions, which are normally disallowed for current role.

Affected Products

  • Oracle GraalVM Enterprise Edition 20.3.7, 21.3.3, 22.2.0
    Oracle Java SE 8u341, 11.0.16.1, 17.0.4.1, 19

5.3 Medium

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

LOW

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

7.3 High

AI Score

Confidence

High

0.002 Low

EPSS

Percentile

59.6%