Lucene search

K
kasperskyKaspersky LabKLA12040
HistoryJan 12, 2021 - 12:00 a.m.

KLA12040 Multiple vulnerability in Microsoft Developer Tools

2021-01-1200:00:00
Kaspersky Lab
threats.kaspersky.com
23

7.2 High

CVSS2

Attack Vector

LOCAL

Attack Complexity

LOW

Authentication

NONE

Confidentiality Impact

COMPLETE

Integrity Impact

COMPLETE

Availability Impact

COMPLETE

AV:L/AC:L/Au:N/C:C/I:C/A:C

7.8 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

8.8 High

AI Score

Confidence

High

0.009 Low

EPSS

Percentile

82.3%

Multiple vulnerabilities were found in Microsoft Developer Tools. Malicious users can exploit these vulnerabilities to gain privileges, execute arbitrary code, cause denial of service, obtain sensitive information.

Below is a complete list of vulnerabilities:

  1. An elevation of privilege vulnerability in Diagnostics Hub Standard Collector can be exploited remotely to gain privileges.
  2. A remote code execution vulnerability in Visual Studio can be exploited remotely to execute arbitrary code.
  3. A denial of service vulnerability in ASP.NET Core and Visual Studio can be exploited remotely to cause denial of service.
  4. An information disclosure vulnerability in Bot Framework SDK can be exploited remotely to obtain sensitive information.

Original advisories

CVE-2021-1651

CVE-2021-1680

CVE-2020-26870

CVE-2021-1723

CVE-2021-1725

Related products

Microsoft-.NET-Framework

Microsoft-Visual-Studio

Microsoft-Windows

Microsoft-Windows-Server

Microsoft-Windows-10

CVE list

CVE-2021-1651 critical

CVE-2021-1680 critical

CVE-2020-26870 high

CVE-2021-1723 critical

CVE-2021-1725 high

KB list

4584787

Solution

Install necessary updates from the KB section, that are listed in your Windows Update (Windows Update usually can be accessed from the Control Panel)

Impacts

  • ACE

Arbitrary code execution. Exploitation of vulnerabilities with this impact can lead to executing by abuser any code or commands at vulnerable machine or process.

  • OSI

Obtain sensitive information. Exploitation of vulnerabilities with this impact can lead to capturing by abuser information, critical for user or system.

  • DoS

Denial of service. Exploitation of vulnerabilities with this impact can lead to loss of system availability or critical functional fault.

  • PE

Privilege escalation. Exploitation of vulnerabilities with this impact can lead to performing by abuser actions, which are normally disallowed for current role.

Affected Products

  • Microsoft Visual Studio 2019 version 16.0Windows 10 Version 1909 for ARM64-based SystemsWindows 10 Version 1809 for x64-based SystemsWindows 10 Version 20H2 for ARM64-based SystemsWindows Server, version 2004 (Server Core installation)Windows 10 Version 1607 for 32-bit SystemsMicrosoft Visual Studio 2019 version 16.7 (includes 16.0 – 16.6)Microsoft Visual Studio 2019 version 16.8Windows 10 Version 1803 for 32-bit SystemsMicrosoft Visual Studio 2015 Update 3Windows 10 Version 1909 for 32-bit SystemsASP.NET Core 5.0Windows Server, version 20H2 (Server Core Installation)Windows 10 Version 1803 for x64-based SystemsWindows 10 Version 2004 for 32-bit SystemsWindows 10 Version 2004 for ARM64-based SystemsWindows Server 2019Windows 10 Version 2004 for x64-based SystemsMicrosoft Visual Studio 2017 version 15.9 (includes 15.0 - 15.8)Windows Server, version 1909 (Server Core installation)Windows Server 2016Windows 10 Version 1809 for 32-bit SystemsWindows 10 Version 1809 for ARM64-based SystemsWindows 10 Version 1803 for ARM64-based SystemsWindows Server 2016 (Server Core installation)Windows 10 Version 1607 for x64-based SystemsWindows 10 Version 20H2 for 32-bit SystemsWindows 10 for 32-bit SystemsWindows 10 Version 20H2 for x64-based SystemsASP.NET Core 3.1Microsoft Visual Studio 2019 version 16.4 (includes 16.0 - 16.3)Windows 10 for x64-based SystemsBot Framework SDK for .NET FrameworkWindows Server 2019 (Server Core installation)Bot Framework SDK for PythonBot Framework SDK for JavaScriptWindows 10 Version 1909 for x64-based Systems

7.2 High

CVSS2

Attack Vector

LOCAL

Attack Complexity

LOW

Authentication

NONE

Confidentiality Impact

COMPLETE

Integrity Impact

COMPLETE

Availability Impact

COMPLETE

AV:L/AC:L/Au:N/C:C/I:C/A:C

7.8 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

8.8 High

AI Score

Confidence

High

0.009 Low

EPSS

Percentile

82.3%