Lucene search

K
kasperskyKaspersky LabKLA11229
HistoryMar 23, 2018 - 12:00 a.m.

KLA11229 Multiple vulnerabilities in Mozilla Thunderbird

2018-03-2300:00:00
Kaspersky Lab
threats.kaspersky.com
34

7.5 High

CVSS2

Attack Vector

NETWORK

Attack Complexity

LOW

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:N/C:P/I:P/A:P

9.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

9.6 High

AI Score

Confidence

High

0.38 Low

EPSS

Percentile

97.2%

Multiple vulnerabilities were found in Mozilla Thunderbird. Malicious users can exploit these vulnerabilities to cause denial of service, execute arbitrary code, bypass security restrictions.

Below is a complete list of vulnerabilities:

  1. A buffer overflow vulnerability can be exploited remotely via specially crafted script to cause denial of service;
  2. An out-of-bounds memory write vulnerability can be exploited remotely via specially crafted IPC messages to bypass security restrictions and execute arbitrary code;
  3. An integer overflow vulnerability can be exploited remotely to cause denial of service;
  4. Out of bounds memory write vulnerability in libvorbis can be exploited to bypass security restrictions;
  5. An out-of-bounds memory write in libvorbis can be exploited remotely possibly to execute arbitrary code;
  6. Memory corruption vulnerability can be exploited remotely to execute arbitrary code;

Original advisories

Mozilla Foundation Security Advisory 2018-09

Exploitation

Malware exists for this vulnerability. Usually such malware is classified as Exploit. More details.

Related products

Mozilla-Thunderbird

CVE list

CVE-2018-5127 high

CVE-2018-5129 warning

CVE-2018-5144 critical

CVE-2018-5146 high

CVE-2018-5125 high

CVE-2018-5145 critical

Solution

Update to the latest version

Download Mozilla Thunderbird

Impacts

  • ACE

Arbitrary code execution. Exploitation of vulnerabilities with this impact can lead to executing by abuser any code or commands at vulnerable machine or process.

  • DoS

Denial of service. Exploitation of vulnerabilities with this impact can lead to loss of system availability or critical functional fault.

  • SB

Security bypass. Exploitation of vulnerabilities with this impact can lead to performing actions restricted by current security settings.

Affected Products

  • Mozilla Thunderbird earlier thanΒ 52.7

7.5 High

CVSS2

Attack Vector

NETWORK

Attack Complexity

LOW

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:N/C:P/I:P/A:P

9.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

9.6 High

AI Score

Confidence

High

0.38 Low

EPSS

Percentile

97.2%