Lucene search

K
jvnJapan Vulnerability NotesJVN:51176027
HistoryJun 19, 2012 - 12:00 a.m.

JVN#51176027: Python SimpleHTTPServer vulnerable to cross-site scripting

2012-06-1900:00:00
Japan Vulnerability Notes
jvn.jp
48

2.6 Low

CVSS2

Attack Vector

NETWORK

Attack Complexity

HIGH

Authentication

NONE

Confidentiality Impact

NONE

Integrity Impact

PARTIAL

Availability Impact

NONE

AV:N/AC:H/Au:N/C:N/I:P/A:N

0.004 Low

EPSS

Percentile

74.4%

The SimpleHTTPServer in Python contains a cross-site scripting vulnerability.

Impact

An arbitrary script may be executed on the user’s Internet Explorer.

According to the developer, this issue exists only when using Internet Explorer 7.

Solution

Update the software
Update to the latest version according to the information provided by the developer.

Products Affected

  • Python versions prior to 2.7.2
  • Python versions prior to 2.6.7 rc2
  • Python versions prior to 2.5.6c1

2.6 Low

CVSS2

Attack Vector

NETWORK

Attack Complexity

HIGH

Authentication

NONE

Confidentiality Impact

NONE

Integrity Impact

PARTIAL

Availability Impact

NONE

AV:N/AC:H/Au:N/C:N/I:P/A:N

0.004 Low

EPSS

Percentile

74.4%