logo
DATABASE RESOURCES PRICING ABOUT US

JVN#44550983: Strapi vulnerable to cross-site scripting

Description

Strapi contains a stored cross-site scripting vulnerability (CWE-79) in the file upload function. ## Impact An arbitrary script may be executed on the web browser of the user who is logging in to the product with the administrative privilege. ## Solution **Update the Software** Update the software to the latest version according to the information provided by the developer. According to the developer, this vulnerability is fixed in Strapi v4.x.x versions and v3.x.x versions are planned to be end-of-life in September, 2022. ## Products Affected * Strapi v3.x.x versions and earlier


Related