Lucene search

K
ibmIBMDDCE3DF1C0F2F3507A59F94E81A8ADEA101DC8CB5DCFAEE3754B7E7CBB0C41CB
HistoryJun 18, 2018 - 12:09 a.m.

Security Bulletin: Vulnerabilities in SSL and TLS protocols affect the IBM FlashSystem V840 (CVE-2011-3389)

2018-06-1800:09:28
www.ibm.com
9

4.3 Medium

CVSS2

Access Vector

NETWORK

Access Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

NONE

Availability Impact

NONE

AV:N/AC:M/Au:N/C:P/I:N/A:N

0.009 Low

EPSS

Percentile

82.3%

Summary

SSL and TLS vulnerabilities were disclosed in September 2011. This vulnerability has been referred to as the “BEAST” attack. SSL protocol is used by the IBM FlashSystem V840.

Vulnerability Details

CVE-ID: CVE-2011-3389

DESCRIPTION: Multiple products could allow a remote attacker to obtain sensitive information, caused by a design error in the Secure Sockets Layer (SSL) and Transport Layer Security (TLS) protocols when using a Cipher-Block Chaining (CBC) based cryptographic algorithm. By persuading a victim to visit a Web site, a remote attacker could exploit this vulnerability using man-in-the-middle techniques to decrypt HTTPS sessions and obtain sensitive information.

CVSS Base Score: 4.3
CVSS Temporal Score: See http://xforce.iss.net/xforce/xfdb/70069 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (AV:N/AC:M/Au:N/C:P/I:N/A:N)

Affected Products and Versions

IBM FlashSystem V840 including machine type and models (MTMs) for all available code levels. MTMs affected include 9846-AC0, 9846-AC1, 9848-AC0, and 9848-AC1.

Remediation/Fixes

Product

| VRMF| APAR| Remediation/First Fix
—|—|—|—
FlashSystem V840 MTMs:

9846-AE1,

9848-AE1,

9846-AC0,

9846-AC1,

9848-AC0,

9848-AC1

| A code fix is now available. The VRMF of this code level is 1.1.3.8 (or later) for the storage enclosure nodes (-AEx) and 7.4.0.4 for the control nodes (-ACx)| None| This vulnerability has been remediated in firmware versions 1.1.3.8 (-AEx) and 7.4.0.4 (-ACx)

For firmware versions released earlier than 1.1.3.8 for the storage enclosure nodes and 7.4.0.4 for the control nodes, IBM recommends upgrading to a fixed, supported version/release/platform of the product.

For both enclosure types (-AEx & -ACx):
You should verify applying this fix does not cause any compatibility issues. The fix is being released with the fix to the Bar Mitzvah attack and so disables RC4 stream cipher in all cases and does not allow it to be re-enabled. Even so, if you change the security setting you will expose yourself to the BEAST attack described above. IBM recommends that you review your entire environment to identify levels of SSL protocol being used.

The system is vulnerable until all enclosures have their SSL protocol level is set to 3 using “chsecurity”.

_For the control nodes (-ACx): _
Once you have upgraded the system you should use the CLI command “lssecurity” to determine the current minimum level of SSL protocol allowed. If it is less than level 3 (which allows only TLS 1.2 with ciphers exclusive to TLS 1.2) then modify it with CLI command “chsecurity”. This could cause systems connected to this system via SSL to stop working because they require upgrade or reconfiguration to allow them to use TLS 1.2 with exclusive ciphers. Upgrade those systems or use “chsecurity” again to reduce the minimum level this system uses until the connection works again.

SAN Volume Controller 7.4 Knowledge Center - lssecurity command
SAN Volume Controller 7.4 Knowledge Centre - chsecurity command

For the storage enclosures (-AEx):
You should verify applying this fix does not cause any compatibility issues. The fix is being released with the fix to the Bar Mitzvah attack and so disables RC4 stream cipher in all cases and does not allow it to be re-enabled. Even so, if you change the security setting you will expose yourself to the BEAST attack described above. IBM recommends that you review your entire environment to identify levels of SSL protocol being used.

Once you have upgraded the system with this fix you should use the CLI command:

svcinfo lssecurity

to determine the current minimum level of SSL protocol allowed. If it is less than level 3 (which allows only TLS 1.2 with ciphers exclusive to TLS 1.2), then modify it with CLI command:

svctask chsecurity –sslprotocol 3

This could cause systems connected to this system via SSL to stop working because they require upgrade or reconfiguration to allow them to use TLS 1.2 with exclusive ciphers. Upgrade those systems or use “svctask chsecurity” again to reduce the minimum level this system uses until the connection works again.

For firmware versions released earlier than 1.1.3.8, IBM recommends upgrading to a fixed, supported version/release/platform of the product.

Link to FlashSystem V840 fixes

Workarounds and Mitigations

Although IBM recommends that you install a level of code with a fix for this vulnerability, you can mitigate, although not eliminate, your risk until you have done so by ensuring that all users who have access to the system are authenticated by another security system such as a firewall.

CPENameOperatorVersion
ibm flashsystem softwareeqany

4.3 Medium

CVSS2

Access Vector

NETWORK

Access Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

NONE

Availability Impact

NONE

AV:N/AC:M/Au:N/C:P/I:N/A:N

0.009 Low

EPSS

Percentile

82.3%