Lucene search

K
ibmIBMD28A33DD6F9F0616BF17BE9435C16BA5747AE3606D1B535CC4C8068BCF7BF4EB
HistoryJun 17, 2018 - 5:19 a.m.

Security Bulletin: Security vulnerabilities in Apache Tomcat affect Rational Reporting for Development Intelligence (CVE-2016-6816, CVE-2016-8735)

2018-06-1705:19:05
www.ibm.com
12

EPSS

0.737

Percentile

98.1%

Summary

The Rational Reporting for Development Intelligence (RRDI) is shipped with a version of the Apache Tomcat web server which contains security vulnerabilities that could have a potential security impact.

Vulnerability Details

CVEID: CVE-2016-6816**
DESCRIPTION:** Apache Tomcat is vulnerable to HTTP response splitting attacks, caused by improper validation of user-supplied input. A remote attacker could exploit this vulnerability to inject arbitrary HTTP headers and cause the server to return a split response, once the URL is clicked. This would allow the attacker to perform further attacks, such as Web cache poisoning or cross-site scripting, and possibly obtain sensitive information.
CVSS Base Score: 6.1
CVSS Temporal Score: See <https://exchange.xforce.ibmcloud.com/vulnerabilities/119158&gt; for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N)

CVEID: CVE-2016-8735**
DESCRIPTION:** Apache Tomcat could allow a remote attacker to execute arbitrary code on the system, caused by an error in the JmxRemoteLifecycleListener. By sending specially crafted data to a JMX port, an attacker could exploit this vulnerability to execute arbitrary code on the system with elevated privileges.
CVSS Base Score: 7.3
CVSS Temporal Score: See <https://exchange.xforce.ibmcloud.com/vulnerabilities/119157&gt; for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L)

Affected Products and Versions

Principal Product and Version(s)

| Affected Supporting Product(s) and Version(s)
—|—
RRDI 2.0, 2.0.1, 2.0.3 and 2.0.4| Cognos BI 10.1.1
RRDI 2.0.5 and 2.0.6| Cognos BI 10.2.1
RRDI 5.0, 5.0.1 and 5.0.2| Cognos BI 10.2.1 Fix pack 2
Jazz Reporting Service 5.0, 5.0.1 and 5.0.2

Remediation/Fixes

Apply the recommended fixes to all affected versions of RRDI.

RRDI 2.0, 2.0.0.1, 2.0.1, 2.0.3 and 2.0.4

RRDI 2.0.5 and 2.0.6

RRDI 5.0 and 5.0.1 and 5.0.2

  1. If the Data Collection Component (DCC) or Jazz Reporting Service (JRS, also known as Report Builder) is used, perform this step first.
    Review the topics in Security Bulletin: Multiple security vulnerabilities have been identified in Jazz Team Server shipped with Jazz Reporting Service (CVE-2016-6816,CVE-2016-8735) for addressing the listed vulnerability in the underlying Jazz Team Server.

  2. If the Cognos-based reporting server is used, also perform this step.
    Download the IBM Cognos Business Intelligence 10.2.1.1 Interim Fix 18 (Implemented by file 10.2.5012.504).
    Review technote 1679283: Installing Cognos Business Intelligence 10.2.1.x fix pack in Rational Reporting for Development Intelligence 2.0.x/5.0.x and Rational Insight 1.1.1.x for the detailed instructions for patch application.

Workarounds and Mitigations

None