Lucene search

K
ibmIBM4CE2962069C84188ED5C475A4FF9247D99A8E2652692C99799F35DF8DAE7F96C
HistoryMar 29, 2023 - 1:48 a.m.

Security Bulletin: Vulnerability in Apache Tomcat affects SAN Volume Controller, Storwize family and FlashSystem V9000 products (CVE-2017-5647)

2023-03-2901:48:02
www.ibm.com
27
apache tomcat
san volume controller
storwize family
flashsystem v9000
cve-2017-5647
vulnerability
management gui
ibm
upgrade
security
mitigation

5 Medium

CVSS2

Attack Vector

NETWORK

Attack Complexity

LOW

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

NONE

Availability Impact

NONE

AV:N/AC:L/Au:N/C:P/I:N/A:N

7.5 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

NONE

Availability Impact

NONE

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

0.003 Low

EPSS

Percentile

68.7%

Summary

A vulnerability in the Apache Tomcat component affects the Management GUI of SAN Volume Controller, Storwize family and FlashSystem V9000 products. The Command Line Interface is unaffected.

Vulnerability Details

CVEID: CVE-2017-5647**
DESCRIPTION:** Apache Tomcat could allow a remote attacker to obtain sensitive information, caused by an error in the processing of pipelined requests in send file. An attacker could exploit this vulnerability to obtain sensitive information from the wrong response.
CVSS Base Score: 5.3
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/124400 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N)

Affected Products and Versions

IBM SAN Volume Controller
IBM Storwize V7000
IBM Storwize V5000
IBM Storwize V3700
IBM Storwize V3500
IBM FlashSystem V9000

All products are affected when running supported versions 7.4 to 7.8.

Remediation/Fixes

IBM recommends that you fix this vulnerability by upgrading affected versions of IBM SAN Volume Controller, IBM Storwize V7000, V5000, V3700 and V3500 to the following code levels or higher:

7.5.0.13
7.6.1.8
7.7.1.8
7.8.1.4
8.1.0.2

Latest SAN Volume Controller Code
Latest Storwize V7000 Code
Latest Storwize V5000 Code
Latest Storwize V3700 Code
Latest Storwize V3500 Code

For IBM FlashSystem V9000, upgrade to the following code levels or higher:

7.5.1.6
7.6.1.8
7.7.1.8
7.8.1.4
8.1.0.2

Latest FlashSystem V9000 Code

For unsupported versions of the above products, IBM recommends upgrading to a fixed, supported version of code.

Workarounds and Mitigations

Although IBM recommends that you install a level of code with a fix for this vulnerability, you can mitigate, although not eliminate, your risk until you have done so by ensuring that all users who have access to the system are authenticated by another security system such as a firewall.

Affected configurations

Vulners
Node
ibmstorwize_v7000Match6.1
OR
ibmstorwize_v7000Match6.2
OR
ibmstorwize_v7000Match6.3
OR
ibmstorwize_v7000Match6.4
OR
ibmstorwize_v7000Match7.1
OR
ibmstorwize_v7000Match7.2
OR
ibmstorwize_v7000Match7.3
OR
ibmstorwize_v7000Match7.4
OR
ibmstorwize_v7000Match7.5
OR
ibmstorwize_v7000Match7.6
OR
ibmstorwize_v7000Match7.6.1
OR
ibmstorwize_v7000Match7.7
OR
ibmstorwize_v7000Match7.7.1
OR
ibmstorwize_v7000Match7.8
OR
ibmstorwize_v3700Matchany
OR
ibmstorwize_v5000Matchany
OR
ibmsan_volume_controllerMatchany
OR
ibmflashsystem_v9000Matchany

5 Medium

CVSS2

Attack Vector

NETWORK

Attack Complexity

LOW

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

NONE

Availability Impact

NONE

AV:N/AC:L/Au:N/C:P/I:N/A:N

7.5 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

NONE

Availability Impact

NONE

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

0.003 Low

EPSS

Percentile

68.7%