Apache Httpd < 2.4.30: Possible out of bound access after failure in reading the HTTP request

2018-01-23T00:00:00
ID HTTPD:B6CF5630624F83951A477D36DC8FD634
Type httpd
Reporter The issue was discovered by Robert Swiecki, bug found by honggfuzz.
Modified 2018-03-21T00:00:00

Description

A specially crafted request could have crashed the Apache HTTP Server prior to version 2.4.30, due to an out of bound access after a size limit is reached by reading the HTTP header. This vulnerability is considered very hard if not impossible to trigger in non-debug mode (both log and build level), so it is classified as low risk for common server usage.