Multiple XSS in pragmaMx

2012-05-02T00:00:00
ID HTB23090
Type htbridge
Reporter High-Tech Bridge
Modified 2012-05-21T00:00:00

Description

High-Tech Bridge SA Security Research Lab has discovered multiple vulnerabilities in pragmaMx, which can be exploited to perform Cross-Site Scripting (XSS) attacks.

1) Multiple Cross-Site Scripting (XSS) in pragmaMx: CVE-2012-2452
1.1 Input passed via a name of a GET parameter to modules.php is not properly sanitised before being returned to the user.
This can be exploited to execute arbitrary HTML and script code in administrator's browser session in context of affected website.
The following PoC (Proof of Concept) demonstrates the vulnerability:
http://[host]/modules.php?name=Themetest&%22%3E%3Cscript%3Ealert%28%22XSS%22 %29;%3C/script%3E
1.2 Input passed via the "img_url" GET parameter to /includes/wysiwyg/spaw/editor/plugins/imgpopup/img_popup.php is not properly sanitised before being returned to the user.
This can be exploited to execute arbitrary HTML and script code in user's browser session in context of affected website.
The following PoC (Proof of Concept) demonstrates the vulnerability:
http://[host]/includes/wysiwyg/spaw/editor/plugins/imgpopup/img_popup.php?im g_url=%22%3E%3Cscript%3Ealert%28document.cookie%29;%3C/script%3E