Moderate severity vulnerability that affects activerecord

2017-10-24T18:33:36
ID GHSA-XRR6-3PC4-M447
Type github
Reporter GitHub Advisory Database
Modified 2019-07-03T21:01:59

Description

activerecord/lib/active_record/nested_attributes.rb in Active Record in Ruby on Rails 3.1.x and 3.2.x before 3.2.22.1, 4.0.x and 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 does not properly implement a certain destroy option, which allows remote attackers to bypass intended change restrictions by leveraging use of the nested attributes feature.