Moderate severity vulnerability that affects org.springframework.data:spring-data-jpa

2019-06-04T15:42:15
ID GHSA-XGGX-FX6W-V7CH
Type github
Reporter GitHub Advisory Database
Modified 2019-10-10T20:53:41

Description

This affects Spring Data JPA in versions up to and including 2.1.6, 2.0.14 and 1.11.20. ExampleMatcher using ExampleMatcher.StringMatcher.STARTING, ExampleMatcher.StringMatcher.ENDING or ExampleMatcher.StringMatcher.CONTAINING could return more results than anticipated when a maliciously crafted example value is supplied.