High severity vulnerability that affects windows-iedriver

2019-02-18T23:41:58
ID GHSA-W9MF-24H3-9WXF
Type github
Reporter GitHub Advisory Database
Modified 2019-07-03T21:02:06

Description

The windows-iedriver module downloads fixed version of iedriverserver.exe windows-iedriver downloads binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested resources with an attacker controlled copy if the attacker is on the network or positioned in between the user and the remote server.