Moderate severity vulnerability that affects io.swagger:swagger-codegen and io.swagger:swagger-parser

2018-10-19T16:46:30
ID GHSA-VGVF-9JH3-FG75
Type github
Reporter GitHub Advisory Database
Modified 2019-07-03T21:02:05

Description

A vulnerability in Swagger-Parser's version <= 1.0.30 and Swagger codegen version <= 2.2.2 yaml parsing functionality results in arbitrary code being executed when a maliciously crafted yaml Open-API specification is parsed. This in particular, affects the 'generate' and 'validate' command in swagger-codegen (<= 2.2.2) and can lead to arbitrary code being executed when these commands are used on a well-crafted yaml specification.