Lucene search

K
githubGitHub Advisory DatabaseGHSA-VCC3-RW6F-JV97
HistoryMar 18, 2024 - 8:38 p.m.

Use-after-free in libxml2 via Nokogiri::XML::Reader

2024-03-1820:38:40
CWE-416
GitHub Advisory Database
github.com
28
nokogiri
libxml2
upgrade
vulnerability
use-after-free

6.6 Medium

AI Score

Confidence

High

Summary

Nokogiri upgrades its dependency libxml2 as follows:

  • v1.15.6 upgrades libxml2 to 2.11.7 from 2.11.6
  • v1.16.2 upgrades libxml2 to 2.12.5 from 2.12.4

libxml2 v2.11.7 and v2.12.5 address the following vulnerability:

CVE-2024-25062 / https://vulners.com/cve/CVE-2024-25062

Please note that this advisory only applies to the CRuby implementation of Nokogiri, and only if
the packaged libraries are being used. If you’ve overridden defaults at installation time to use
system libraries instead of packaged libraries, you should instead pay attention to your distro’s
libxml2 release announcements.

JRuby users are not affected.

Severity

The Nokogiri maintainers have evaluated this as Moderate.

Impact

From the CVE description, this issue applies to the xmlTextReader module (which underlies
Nokogiri::XML::Reader):

> When using the XML Reader interface with DTD validation and XInclude expansion enabled,
> processing crafted XML documents can lead to an xmlValidatePopElement use-after-free.

Mitigation

Upgrade to Nokogiri ~> 1.15.6 or >= 1.16.2.

Users who are unable to upgrade Nokogiri may also choose a more complicated mitigation: compile
and link Nokogiri against patched external libxml2 libraries which will also address these same
issues.

CPENameOperatorVersion
nokogirilt1.16.2
nokogirilt1.15.6