Moderate severity vulnerability that affects spree

2017-10-24T18:33:37
ID GHSA-JXX8-V83V-RHW3
Type github
Reporter GitHub Advisory Database
Modified 2019-07-03T21:02:00

Description

Spree Commerce 1.0.x through 1.3.2 allows remote authenticated administrators to instantiate arbitrary Ruby objects and execute arbitrary commands via the (1) payment_method parameter to core/app/controllers/spree/admin/payment_methods_controller.rb; and the (2) promotion_action parameter to promotion_actions_controller.rb, (3) promotion_rule parameter to promotion_rules_controller.rb, and (4) calculator_type parameter to promotions_controller.rb in promo/app/controllers/spree/admin/, related to unsafe use of the constantize function.