Moderate severity vulnerability that affects devise

2017-10-24T18:33:37
ID GHSA-JXHW-MG8M-2PJ8
Type github
Reporter GitHub Advisory Database
Modified 2019-07-03T21:02:00

Description

Devise gem 2.2.x before 2.2.3, 2.1.x before 2.1.3, 2.0.x before 2.0.5, and 1.5.x before 1.5.4 for Ruby, when using certain databases, does not properly perform type conversion when performing database queries, which might allow remote attackers to cause incorrect results to be returned and bypass security checks via unknown vectors, as demonstrated by resetting passwords of arbitrary accounts.