Lucene search

K
githubGitHub Advisory DatabaseGHSA-H8G9-6GVH-5MRC
HistoryOct 06, 2022 - 11:12 p.m.

etcd vulnerable to TOCTOU of gateway endpoint authentication

2022-10-0623:12:38
CWE-367
GitHub Advisory Database
github.com
7

Vulnerability type

Authentication

Workarounds

Refer to the gateway documentation. The vulnerability was spotted due to unclear documentation of how the gateway handles endpoints validation.

Detail

The gateway only authenticates endpoints detected from DNS SRV records, and it only authenticates the detected endpoints once. Therefore, if an endpoint changes its authentication settings, the gateway will continue to assume the endpoint is still authenticated. The auditors has noted that appropriate documentation of this validation functionality plus deprecation of this misleading functionality is an acceptable path forward.

References

Find out more on this vulnerability in the security audit report

For more information

If you have any questions or comments about this advisory:

Affected configurations

Vulners
Node
github_advisory_databasego.etcd.io\/etcd\/v3Range<3.3.23
OR
github_advisory_databasego.etcd.io\/etcd\/v3Range<3.4.10