Prototype Pollution in upmerge

2019-06-06T15:32:28
ID GHSA-GM9G-2G8V-FVXJ
Type github
Reporter GitHub Advisory Database
Modified 2020-08-31T18:36:35

Description

All versions of upmerge are vulnerable to Prototype Pollution. The merge() function fails to prevent user input to alter an Object's prototype, allowing attackers to modify override properties of all objects in the application. This may lead to Denial of Service or may be chained with other vulnerabilities leading to Remote Code Execution.

Recommendation

No fix is currently available. Consider using an alternative module until a fix is made available.