Denial of Service in @commercial/subtext

2020-09-03T20:33:17
ID GHSA-FVWR-H9XH-M6WC
Type github
Reporter GitHub Advisory Database
Modified 2020-09-03T20:33:17

Description

Versions of @commercial/subtext prior to 5.1.1 are vulnerable to Denial of Service (DoS). The package fails to enforce the maxBytes configuration for payloads with chunked encoding that are written to the file system. This allows attackers to send requests with arbitrary payload sizes, which may exhaust system resources leading to Denial of Service.

Recommendation

Upgrade to version 5.1.1 or later.