Lucene search

K
githubGitHub Advisory DatabaseGHSA-FQ9F-9WV9-RFMG
HistoryMay 14, 2022 - 1:04 a.m.

Improper Certificate Validation in Jenkins

2022-05-1401:04:35
CWE-295
GitHub Advisory Database
github.com
7

0.001 Low

EPSS

Percentile

28.9%

Jenkins 2.73.1 and earlier, 2.83 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks. This library is widely used as a transitive dependency in Jenkins plugins. The fix for CVE-2012-6153 was backported to the version of commons-httpclient that is bundled in core and made available to plugins.