Lucene search

K
githubGitHub Advisory DatabaseGHSA-C58J-88F5-H53F
HistoryJul 05, 2022 - 10:08 p.m.

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in pycares

2022-07-0522:08:20
CWE-79
GitHub Advisory Database
github.com
19
pycares
cross-site scripting
cve-2021-3672
update.

6.8 Medium

CVSS2

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:M/Au:N/C:P/I:P/A:P

5.6 Medium

CVSS3

Attack Vector

NETWORK

Attack Complexity

HIGH

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

LOW

Integrity Impact

LOW

Availability Impact

LOW

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

0.002 Low

EPSS

Percentile

52.8%

Impact

pycares versions < 4.2.0 are affected by CVE-2021-3672.

Patches

Update to version 4.2.0.

Affected configurations

Vulners
Node
pycaresRange<4.2.0
CPENameOperatorVersion
pycareslt4.2.0

6.8 Medium

CVSS2

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:M/Au:N/C:P/I:P/A:P

5.6 Medium

CVSS3

Attack Vector

NETWORK

Attack Complexity

HIGH

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

LOW

Integrity Impact

LOW

Availability Impact

LOW

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

0.002 Low

EPSS

Percentile

52.8%