Cross-Site Scripting in graylog-web-interface

2020-09-03T17:10:31
ID GHSA-9QGH-7PGP-HP7R
Type github
Reporter GitHub Advisory Database
Modified 2020-09-03T17:10:31

Description

All versions of graylog-web-interface are vulnerable to Cross-Site Scripting (XSS). The package fails to escape output on the TypeAhead and QueryInput components, which may allow attackers to execute arbitrary JavaScript on the victim's browser.

Recommendation

No fix is currently available. Consider using an alternative package until a fix is made available.