Lucene search

K
githubGitHub Advisory DatabaseGHSA-98WM-3W3Q-MW94
HistorySep 06, 2022 - 12:00 a.m.

snakeYAML before 1.31 vulnerable to Denial of Service due to Out-of-bounds Write

2022-09-0600:00:27
CWE-121
CWE-787
GitHub Advisory Database
github.com
8
snakeyaml
version 1.31
vulnerability
denial of service
out-of-bounds write
parser
untrusted yaml files
stackoverflow
dos
attack

CVSS3

6.5

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

EPSS

0.001

Percentile

46.9%

Using snakeYAML to parse untrusted YAML files may be vulnerable to Denial of Service attacks (DOS). If the parser is running on user supplied input, an attacker may supply content that causes the parser to crash by stackoverflow.

Affected configurations

Vulners
Node
org.yaml\Matchsnakeyaml
CPENameOperatorVersion
org.yaml:snakeyamllt1.31

CVSS3

6.5

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

EPSS

0.001

Percentile

46.9%