Lucene search

K
githubGitHub Advisory DatabaseGHSA-8C56-V25W-F89C
HistoryMay 14, 2022 - 12:56 a.m.

Puppet arbitrary file overwrite

2022-05-1400:56:54
CWE-59
GitHub Advisory Database
github.com
8
puppet
arbitrary file overwrite
vulnerability
symlink attack
.k5login file

CVSS2

6.3

Attack Vector

LOCAL

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

NONE

Integrity Impact

COMPLETE

Availability Impact

COMPLETE

AV:L/AC:M/Au:N/C:N/I:C/A:C

AI Score

6.4

Confidence

Low

EPSS

0

Percentile

5.1%

Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x allows local users to overwrite arbitrary files via a symlink attack on the .k5login file.

Affected configurations

Vulners
Node
puppetpuppetRange<2.7.5
OR
puppetpuppetRange<2.6.11
CPENameOperatorVersion
puppetlt2.7.5
puppetlt2.6.11

CVSS2

6.3

Attack Vector

LOCAL

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

NONE

Integrity Impact

COMPLETE

Availability Impact

COMPLETE

AV:L/AC:M/Au:N/C:N/I:C/A:C

AI Score

6.4

Confidence

Low

EPSS

0

Percentile

5.1%