High severity vulnerability that affects webargs

2019-03-12T15:16:12
ID GHSA-8554-JXCW-454Q
Type github
Reporter GitHub Advisory Database
Modified 2021-09-03T22:58:26

Description

An issue was discovered in webargs before 5.1.3, as used with marshmallow and other products. JSON parsing uses a short-lived cache to store the parsed JSON body. This cache is not thread-safe, meaning that incorrect JSON payloads could have been parsed for concurrent requests.