Moderate severity vulnerability that affects yarn

2020-02-14T23:10:16
ID GHSA-5XF4-F2FQ-F69J
Type github
Reporter GitHub Advisory Database
Modified 2020-02-14T23:10:16

Description

In Yarn before 1.21.1, the package install functionality can be abused to generate arbitrary symlinks on the host filesystem by using specially crafted "bin" keys. Existing files could be overwritten depending on the current user permission set.