High severity vulnerability that affects actionpack

2017-10-24T18:33:38
ID GHSA-4WW3-3RXJ-8V6Q
Type github
Reporter GitHub Advisory Database
Modified 2019-07-03T21:02:00

Description

actionpack/lib/action_view/template/resolver.rb in Ruby on Rails 3.0.x before 3.0.4, when a case-insensitive filesystem is used, does not properly implement filters associated with the list of available templates, which allows remote attackers to bypass intended access restrictions via an action name that uses an unintended case for alphabetic characters.