logo
DATABASE RESOURCES PRICING ABOUT US

Moderate severity vulnerability that affects django

Description

The verify_exists functionality in the URLField implementation in Django before 1.2.7 and 1.3.x before 1.3.1 relies on Python libraries that attempt access to an arbitrary URL with no timeout, which allows remote attackers to cause a denial of service (resource consumption) via a URL associated with (1) a slow response, (2) a completed TCP connection with no application data sent, or (3) a large amount of application data, a related issue to CVE-2011-1521.


Affected Software


CPE Name Name Version
django 1.3.0
django 1.3.1
django 1.2.0
django 1.2.7

Related