Lucene search

K
githubGitHub Advisory DatabaseGHSA-26QX-4M49-6CFR
HistoryNov 08, 2023 - 3:30 a.m.

wildfly-core Exposure of Sensitive Information to an Unauthorized Actor vulnerability

2023-11-0803:30:32
CWE-200
GitHub Advisory Database
github.com
6
wildfly-core management user hal interface

CVSS3

6.5

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

NONE

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

AI Score

6.5

Confidence

Low

EPSS

0.001

Percentile

32.5%

A flaw was found in wildfly-core. A management user could use the resolve-expression in the HAL Interface to read possible sensitive information from the Wildfly system. This issue could allow a malicious user to access the system and obtain possible sensitive information from the system.

Affected configurations

Vulners
Node
org.wildfly.core\wildflyMatchcontroller

CVSS3

6.5

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

NONE

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

AI Score

6.5

Confidence

Low

EPSS

0.001

Percentile

32.5%