Lucene search

K
gentooGentoo FoundationGLSA-202311-11
HistoryNov 25, 2023 - 12:00 a.m.

QtWebEngine: Multiple Vulnerabilities

2023-11-2500:00:00
Gentoo Foundation
security.gentoo.org
26
qtwebengine
vulnerabilities
upgrade

8.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

8.1 High

AI Score

Confidence

Low

0.771 High

EPSS

Percentile

98.2%

Background

QtWebEngine is a library for rendering dynamic web content in Qt5 and Qt6 C++ and QML applications.

Description

Multiple vulnerabilities have been discovered in QtWebEngine. Please review the CVE identifiers referenced below for details.

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

Resolution

All QtWebEngine users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-qt/qtwebengine-5.15.10_p20230623"
OSVersionArchitecturePackageVersionFilename
Gentooanyalldev-qt/qtwebengine< 5.15.10_p20230623UNKNOWN

8.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

8.1 High

AI Score

Confidence

Low

0.771 High

EPSS

Percentile

98.2%