D-Bus: Denial of service

2020-07-27T00:00:00
ID GLSA-202007-46
Type gentoo
Reporter Gentoo Foundation
Modified 2020-07-27T00:00:00

Description

Background

D-Bus is a message bus system which processes can use to talk to each other.

Description

D-Bus does not correctly dispose of old connections meaning that it is possible for D-Bus to hit a connection limit.

Impact

An attacker could cause a possible Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All D-Bus users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=sys-apps/dbus-1.12.18"