3proxy: Denial of Service

2007-11-08T00:00:00
ID GLSA-200711-13
Type gentoo
Reporter Gentoo Foundation
Modified 2007-11-08T00:00:00

Description

Background

3proxy is a really tiny cross-platform proxy servers set, including HTTP, HTTPS, FTP, SOCKS and POP3 support.

Description

3proxy contains a double free vulnerability in the ftpprchild() function, which frees param->hostname and calls the parsehostname() function, which in turn attempts to free param->hostname again.

Impact

A remote attacker could send a specially crafted request to the proxy, possibly resulting in a Denial of Service. Under typical configuration, the scope of this vulnerability is limited to the local network.

Workaround

There is no known workaround at this time.

Resolution

All 3proxy users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-proxy/3proxy-0.5.3j"