libapreq2: Denial of Service vulnerability

2006-04-17T00:00:00
ID GLSA-200604-08
Type gentoo
Reporter Gentoo Foundation
Modified 2006-04-17T00:00:00

Description

Background

libapreq is a shared library with associated modules for manipulating client request data via the Apache API.

Description

A vulnerability has been reported in the apreq_parse_headers() and apreq_parse_urlencoded() functions of Apache2::Request.

Impact

A remote attacker could possibly exploit the vulnerability to cause a Denial of Service by CPU consumption.

Workaround

There is no known workaround at this time.

Resolution

All libapreq2 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apache/libapreq2-2.07"