Adobe Acrobat Reader: Buffer overflow vulnerability

2005-07-11T00:00:00
ID GLSA-200507-09
Type gentoo
Reporter Gentoo Foundation
Modified 2005-07-11T00:00:00

Description

Background

Adobe Acrobat Reader is a utility used to view PDF files.

Description

A buffer overflow has been discovered in the UnixAppOpenFilePerform() function, which is called when Adobe Acrobat Reader tries to open a file with the "\Filespec" tag.

Impact

By enticing a user to open a specially crafted PDF document, a remote attacker could exploit this vulnerability to execute arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

Since Adobe will most likely not update the 5.0 series of Adobe Acrobat Reader for Linux, all users should upgrade to the latest available version of the 7.0 series:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/acroread-7.0"