gld -- format string and buffer overflow vulnerabilities

2005-04-12T00:00:00
ID 6C2D4F29-AF3E-11D9-837D-000E0C2E438A
Type freebsd
Reporter FreeBSD
Modified 2005-04-12T00:00:00

Description

Gld has been found vulnerable to multiple buffer overflows as well as multiple format string vulnerabilities.

An attacker could exploit this vulnerability to execute arbitrary code with the permissions of the user running Gld, the default user being root.

The FreeBSD port defaults to running gld as the root user. The risk of exploitation can be minimized by making gld listen on the loopback address only, or configure it to only accept connections from trusted smtp servers.