asterisk -- Exploitable Stack and Heap Array Overflows

2011-02-21T00:00:00
ID 65D16342-3EC8-11E0-9DF7-001C42D23634
Type freebsd
Reporter FreeBSD
Modified 2011-02-21T00:00:00

Description

The Asterisk Development Team reports:

The releases of Asterisk 1.4.39.2, 1.6.1.22, 1.6.2.16.2, and 1.8.2.4 resolve an issue that when decoding UDPTL packets, multiple heap based arrays can be made to overflow by specially crafted packets. Systems configured for T.38 pass through or termination are vulnerable. The issue and resolution are described in the AST-2011-002 security advisory.