SOL15282 - Apache Struts vulnerability CVE-2014-0114

2014-05-19T00:00:00
ID SOL15282
Type f5
Reporter f5
Modified 2014-10-20T00:00:00

Description

*F5 Product Development has determined that these specific product versions, while they use a version of Apache Struts that has not been patched specifically for CVE-2014-0114, the Configuration utility inputs are appropriately sanitized to ensure these versions are not vulnerable to the issue indicated by CVE-2014-0114. Beginning in BIG-IP 11.6.0, the version of Apache Struts has been specifically patched for CVE-2014-0114.

Recommended Action

If the previous table lists a version in the Versions known to be not vulnerable column, you can eliminate this vulnerability by upgrading to the listed version. If the table does not list any version in the column, then no upgrade candidate currently exists.

Supplemental Information

  • SOL9970: Subscribing to email notifications regarding F5 products
  • SOL9957: Creating a custom RSS feed to view new and updated documents
  • SOL4602: Overview of the F5 security vulnerability response policy
  • SOL4918: Overview of the F5 critical issue hotfix policy
  • SOL167: Downloading software and firmware from F5