PostgreSQL vulnerability CVE-2018-16850

2020-07-24T21:24:00
ID F5:K98201023
Type f5
Reporter f5
Modified 2021-08-16T21:27:00

Description

postgresql before versions 11.1, 10.6 is vulnerable to a to SQL injection in pg_upgrade and pg_dump via CREATE TRIGGER ... REFERENCING. Using a purpose-crafted trigger definition, an attacker can cause arbitrary SQL statements to run, with superuser privileges. (CVE-2018-16850)

Impact

An attacker may be able to gain elevated privileges and inject arbitrary SQL code.