Lucene search

K
f5F5F5:K94010578
HistoryMar 07, 2017 - 12:00 a.m.

K94010578 : tcpdump vulnerabilities CVE-2016-7940, CVE-2016-7973, CVE-2016-7974, CVE-2016-7983, and CVE-2016-7984

2017-03-0700:00:00
my.f5.com
13

10 High

AI Score

Confidence

High

0.021 Low

EPSS

Percentile

89.3%

Security Advisory Description

The STP parser in tcpdump before 4.9.0 has a buffer overflow in print-stp.c, multiple functions.

The AppleTalk parser in tcpdump before 4.9.0 has a buffer overflow in print-atalk.c, multiple functions.

The IP parser in tcpdump before 4.9.0 has a buffer overflow in print-ip.c, multiple functions.

The BOOTP parser in tcpdump before 4.9.0 has a buffer overflow in print-bootp.c:bootp_print().

The TFTP parser in tcpdump before 4.9.0 has a buffer overflow in print-tftp.c:tftp_print().
Impact
An attacker can gain access to sensitive information. An attacker can also cause a denial of service (DoS) via a crafted pcap file or by sending specially crafted packets to the network segment wheretcpdump is actively capturing network traffic. Thetcpdump program does not use the protocol decoding subsystem, and is therefore not affected by these vulnerabilities when using the-w option to write raw packets to a** pcap** file for offline examination.