Apache HTTPD vulnerability CVE-2017-7679

2017-07-17T19:54:00
ID F5:K75429050
Type f5
Reporter f5
Modified 2018-08-17T21:47:00

Description

F5 Product Development has assigned ID 672667 (BIG-IP), ID 672977 (Enterprise Manager), and ID 431234 (ARX) to this vulnerability. Additionally, BIG-IP iHealth may list Heuristic H75429050 on the Diagnostics > Identified > Low page.

To determine if your release is known to be vulnerable, the components or features that are affected by the vulnerability, and for information about releases or hotfixes that address the vulnerability, refer to the following table.

Product | Versions known to be vulnerable | Versions known to be not vulnerable | Severity | Vulnerable component or feature
---|---|---|---|---
BIG-IP LTM | 13.0.0 - 13.1.1
12.0.0 - 12.1.3
11.4.1 - 11.6.3
11.2.1 | 14.0.0
13.1.0.2
13.0.1
12.1.3.2 | Low | Apache HTTPD (Configuration utility, iControl)
BIG-IP AAM | 13.0.0 - 13.1.1
12.0.0 - 12.1.3
11.4.1 - 11.6.3 | 14.0.0
13.1.0.2
13.0.1
12.1.3.2 | Low | Apache HTTPD (Configuration utility, iControl)
BIG-IP AFM | 13.0.0 - 13.1.1
12.0.0 - 12.1.3
11.4.1 - 11.6.3 | 14.0.0
13.1.0.2
13.0.1
12.1.3.2 | Low | Apache HTTPD (Configuration utility, iControl)
BIG-IP Analytics | 13.0.0 - 13.1.1
12.0.0 - 12.1.3
11.4.1 - 11.6.3
11.2.1 | 14.0.0
13.1.0.2
13.0.1
12.1.3.2 | Low | Apache HTTPD (Configuration utility, iControl)
BIG-IP APM | 13.0.0 - 13.1.1
12.0.0 - 12.1.3
11.4.1 - 11.6.3
11.2.1 | 14.0.0
13.1.0.2
13.0.1
12.1.3.2 | Low | Apache HTTPD (Configuration utility, iControl)
BIG-IP ASM | 13.0.0 - 13.1.1
12.0.0 - 12.1.3
11.4.1 - 11.6.3
11.2.1 | 14.0.0
13.1.0.2
13.0.1
12.1.3.2 | Low | Apache HTTPD (Configuration utility, iControl)
BIG-IP DNS | 13.0.0 - 13.1.1
12.0.0 - 12.1.3 | 14.0.0
13.1.0.2
13.0.1
12.1.3.2 | Low | Apache HTTPD (Configuration utility, iControl)
BIG-IP Edge Gateway | 11.2.1 | None | Low | Apache HTTPD (Configuration utility, iControl)
BIG-IP GTM | 11.4.1 - 11.6.3
11.2.1 | None | Low | Apache HTTPD (Configuration utility, iControl)
BIG-IP Link Controller | 13.0.0 - 13.1.1
12.0.0 - 12.1.3
11.4.1 - 11.6.3
11.2.1 | 14.0.0
13.1.0.2
13.0.1
12.1.3.2 | Low | Apache HTTPD (Configuration utility, iControl)
BIG-IP PEM | 13.0.0 - 13.1.1
12.0.0 - 12.1.3
11.4.1 - 11.6.3 | 14.0.0
13.1.0.2
13.0.1
12.1.3.2 | Low | Apache HTTPD (Configuration utility, iControl)
BIG-IP PSM | 11.4.1 | None | Low | Apache HTTPD (Configuration utility, iControl)
BIG-IP WebAccelerator | 11.2.1 | None | Low | Apache HTTPD (Configuration utility, iControl)
BIG-IP WebSafe | 13.0.0 - 13.1.1
12.0.0 - 12.1.3
11.6.0 - 11.6.3 | 14.0.0
13.1.0.2
13.0.1
12.1.3.2 | Low | Apache HTTPD (Configuration utility, iControl)
ARX | 6.2.0 - 6.4.0 | None | Medium | Management API (disabled by default)
Enterprise Manager | 3.1.1 | None | Low | Apache HTTPD (Configuration utility, iControl)
BIG-IQ Cloud | None | 4.4.0 - 4.5.0 | Not vulnerable1 | None
BIG-IQ Device | None | 4.4.0 - 4.5.0 | Not vulnerable1 | None
BIG-IQ Security | None | 4.4.0 - 4.5.0 | Not vulnerable1 | None
BIG-IQ ADC | None | 4.5.0 | Not vulnerable1 | None
BIG-IQ Centralized Management | None | 5.0.0 - 5.2.0
4.6.0 | Not vulnerable1 | None
BIG-IQ Cloud and Orchestration | None | 1.0.0 | Not vulnerable1 | None
F5 iWorkflow | None | 2.0.0 - 2.2.0 | Not vulnerable1 | None
LineRate | None | 2.5.0 - 2.6.2 | Not vulnerable | None
Traffix SDC | None | 5.0.0 - 5.1.0
4.0.0 - 4.4.0 | Not vulnerable | None

1 The specified products contain the affected code. However, F5 identifies the vulnerability status as Not vulnerable because the attacker cannot exploit the code in default, standard, or recommended configurations.

If you are running a version listed in the Versions known to be vulnerable column, you can eliminate this vulnerability by upgrading to a version listed in the Versions known to be not vulnerable column. If the table lists only an older version than what you are currently running, or does not list a non-vulnerable version, then no upgrade candidate currently exists.

Mitigation

BIG-IP and Enterprise Manager

To mitigate this vulnerability, you should limit access to the Configuration utility to use only secure networks.

ARX

To mitigate this vulnerability, you should limit access to the ARX GUI to use only secure networks. Additionally, you should avoid enabling the API functionality.