NTP input validation vulnerability CVE-2016-1550

2016-05-25T23:38:00
ID F5:K43205719
Type f5
Reporter f5
Modified 2017-07-07T21:11:00

Description

F5 Product Development has assigned ID 591455 (BIG-IP), ID 594057 (BIG-IQ), ID 594059 (Enterprise Manager), ID 507785 (ARX), and INSTALLER-2396 (Traffix) to this vulnerability, and has evaluated the currently supported releases for potential vulnerability. Additionally, BIG-IP iHealth may list Heuristic H43205719 on the Diagnostics > Identified > Low screen.

To determine if your release is known to be vulnerable, the components or features that are affected by the vulnerability, and for information about releases or hotfixes that address the vulnerability, refer to the following table:

Product| Versions known to be vulnerable| Versions known to be not vulnerable| Severity| Vulnerable component or feature
---|---|---|---|---
BIG-IP LTM| 12.0.0 - 12.1.1
11.0.0 - 11.6.1
10.1.0 - 10.2.4| 13.0.0
12.1.2
11.6.1 HF2
11.5.4 HF4| Low| NTP
BIG-IP AAM| 12.0.0 - 12.1.1
11.4.0 - 11.6.1| 13.0.0
12.1.2
11.6.1 HF2
11.5.4 HF4| Low| NTP
BIG-IP AFM| 12.0.0 - 12.1.1
11.3.0 - 11.6.1| 13.0.0
12.1.2
11.6.1 HF2
11.5.4 HF4| Low| NTP
BIG-IP Analytics| 12.0.0 - 12.1.1
11.0.0 - 11.6.1| 13.0.0
12.1.2
11.6.1 HF2
11.5.4 HF4| Low| NTP
BIG-IP APM| 12.0.0 - 12.1.1
11.0.0 - 11.6.1
10.1.0 - 10.2.4| 13.0.0
12.1.2
11.6.1 HF2
​​​​​​​11.5.4 HF4| Low| NTP
BIG-IP ASM| 12.0.0 - 12.1.1
11.0.0 - 11.6.1
10.1.0 - 10.2.4| 13.0.0
12.1.2
11.6.1 HF2
​​​​​​​11.5.4 HF4| Low| NTP
BIG-IP DNS| 12.0.0 - 12.1.1| 13.0.0
12.1.2| Low| NTP
BIG-IP Edge Gateway| 11.0.0 - 11.3.0
10.1.0 - 10.2.4| None| Low| NTP
BIG-IP GTM| 11.0.0 - 11.6.1
10.1.0 - 10.2.4| 11.6.1 HF2
​​​​​​​11.5.4 HF4| Low| NTP
BIG-IP Link Controller| 12.0.0 - 12.1.1
11.0.0 - 11.6.1
10.1.0 - 10.2.4| 13.0.0
12.1.2
11.6.1 HF2
​​​​​​​11.5.4 HF4| Low| NTP
BIG-IP PEM| 12.0.0 - 12.1.1
11.3.0 - 11.6.1| 13.0.0
12.1.2
11.6.1 HF2
​​​​​​​11.5.4 HF4| Low| NTP
BIG-IP PSM| 11.0.0 - 11.4.1
10.1.0 - 10.2.4| None| Low| NTP
BIG-IP WebAccelerator| 11.0.0 - 11.3.0
10.1.0 - 10.2.4| None| Low| NTP
BIG-IP WOM| 11.0.0 - 11.3.0
10.1.0 - 10.2.4| None| Low| NTP
ARX| 6.0.0 - 6.4.0| None| Low| NTP
Enterprise Manager| 3.0.0 - 3.1.1| None| Low| NTP
FirePass| None| 7.0.0
6.0.0 - 6.1.0| Not vulnerable| None
BIG-IQ Cloud| 4.0.0 - 4.5.0| None| Low| NTP
BIG-IQ Device| 4.2.0 - 4.5.0| None| Low| NTP
BIG-IQ Security| 4.0.0 - 4.5.0| None| Low| NTP
BIG-IQ ADC| 4.5.0| None| Low| NTP
BIG-IQ Centralized Management| 4.6.0| None| Low| NTP
BIG-IQ Cloud and Orchestration| 1.0.0| None| Low| NTP
LineRate| None| 2.5.0 - 2.6.1| Not vulnerable| None
F5 MobileSafe| None| 1.0.0| Not vulnerable| None
F5 WebSafe| None| 1.0.0| Not vulnerable| None
Traffix SDC| 5.0.0
4.0.0 - 4.4.0
3.3.2 - 3.5.1| None| Low| NTP

If you are running a version listed in the Versions known to be vulnerable column, you can eliminate this vulnerability by upgrading to a version listed in the Versions known to be not vulnerable column. If the table lists only an older version than what you are currently running, or does not list a non-vulnerable version, then no upgrade candidate currently exists.

To determine the necessary upgrade path for your BIG-IQ system, you should understand the BIG-IQ product offering name changes. For more information, refer to K21232150: Considerations for upgrading BIG-IQ or F5 iWorkflow systems.

Mitigation

None