Lucene search

K
f5F5F5:K24353255
HistoryDec 28, 2018 - 12:00 a.m.

K24353255 : Binutils vulnerabilities CVE-2018-18605, CVE-2018-18606, and CVE-2018-18607

2018-12-2800:00:00
my.f5.com
17

AI Score

5.9

Confidence

High

EPSS

0.004

Percentile

73.5%

Security Advisory Description

A heap-based buffer over-read issue was discovered in the function sec_merge_hash_lookup in merge.c in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.31, because _bfd_add_merge_section mishandles section merges when size is not a multiple of entsize. A specially crafted ELF allows remote attackers to cause a denial of service, as demonstrated by ld.

An issue was discovered in the merge_strings function in merge.c in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.31. There is a NULL pointer dereference in _bfd_add_merge_section when attempting to merge sections with large alignments. A specially crafted ELF allows remote attackers to cause a denial of service, as demonstrated by ld.

An issue was discovered in elf_link_input_bfd in elflink.c in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.31. There is a NULL pointer dereference in elf_link_input_bfd when used for finding STT_TLS symbols without any TLS section. A specially crafted ELF allows remote attackers to cause a denial of service, as demonstrated by ld.

Impact

This vulnerability allows remote attackers to cause a denial of service (DoS) on the affected system.