XSS vulnerability in the BIG-IP and Enterprise Manager Configuration utilities CVE-2015-1470

2015-07-02T21:44:00
ID F5:K16838
Type f5
Reporter f5
Modified 2017-03-10T00:59:00

Description

F5 Product Development has assigned IDs 504016 and 409074 (BIG-IP), and IDs 511249 and 515507 (Enterprise Manager) to this vulnerability, and has evaluated the currently supported releases for potential vulnerability.

To determine if your release is known to be vulnerable, the components or features that are affected by the vulnerability, and for information about releases or hotfixes that address the vulnerability, refer to the following table:

Product| Versions known to be vulnerable| Versions known to be not vulnerable| Severity| Vulnerable component or feature
---|---|---|---|---
BIG-IP LTM| 11.0.0 - 11.6.1
10.0.0 - 10.2.4| 12.0.0| High| Configuration utility
BIG-IP AAM| 11.4.0 - 11.6.1| 12.0.0| High| Configuration utility
BIG-IP AFM| 11.3.0 - 11.6.1| 12.0.0| High| Configuration utility
BIG-IP Analytics| 11.0.0 - 11.6.1| 12.0.0| High| Configuration utility
BIG-IP APM| 11.0.0 - 11.6.1
10.1.0 - 10.2.4| 12.0.0| High| Configuration utility
BIG-IP ASM| 11.0.0 - 11.6.1
10.0.0 - 10.2.4| 12.0.0| High| Configuration utility
BIG-IP DNS| None| 12.0.0| Not vulnerable| None
BIG-IP Edge Gateway| 11.0.0 - 11.3.0
10.1.0 - 10.2.4| None| High| Configuration utility
BIG-IP GTM| 11.0.0 - 11.6.1
10.0.0 - 10.2.4| None| High| Configuration utility
BIG-IP Link Controller| 11.0.0 - 11.6.1
10.0.0 - 10.2.4| 12.0.0| High| Configuration utility
BIG-IP PEM| 11.3.0 - 11.6.1| 12.0.0| High| Configuration utility
BIG-IP PSM| 11.0.0 - 11.4.1
10.0.0 - 10.2.4| None| High| Configuration utility
BIG-IP WebAccelerator| 11.0.0 - 11.3.0
10.0.0 - 10.2.4| None| High| Configuration utility
BIG-IP WOM| 11.0.0 - 11.3.0
10.0.0 - 10.2.4| None| High| Configuration utility
ARX| None| 6.0.0 - 6.4.0| Not vulnerable| None
Enterprise Manager| 3.0.0 - 3.1.1| None| High| Configuration utility
FirePass| None| 7.0.0
6.0.0 - 6.1.0| Not vulnerable| None
BIG-IQ Cloud| None| 4.0.0 - 4.5.0| Not vulnerable| None
BIG-IQ Device| None| 4.2.0 - 4.5.0| Not vulnerable| None
BIG-IQ Security| None| 4.0.0 - 4.5.0| Not vulnerable| None
BIG-IQ ADC| None| 4.5.0| Not vulnerable| None
LineRate| None| 2.5.0 - 2.6.0| Not vulnerable| None
F5 WebSafe| None| 1.0.0| Not vulnerable| None
Traffix SDC| None| 4.0.0 - 4.4.0
3.3.2 - 3.5.1| Not vulnerable| None

Note: As of February 17, 2015, AskF5 Security Advisory articles include the Severity value. Security Advisory articles published before this date do not list a Severity value.

If the previous table lists a version in the Versions known to be not vulnerable column, you can eliminate this vulnerability by upgrading to the listed version. If the listed version is older than the version you are currently running, or if the table does not list any version in the column, then no upgrade candidate currently exists.

To mitigate this vulnerability, you should permit management access to F5 products only over a secure network, and restrict access for affected systems to trusted users. To do so, refer to K13309: Restricting access to the Configuration utility by source IP address (11.x - 12.x) and K13092: Overview of securing access to the BIG-IP system.