PHP vulnerability CVE-2015-4024

2015-07-02T20:42:00
ID F5:K16826
Type f5
Reporter f5
Modified 2016-05-27T18:20:00

Description

F5 Product Development has assigned ID 525232 (BIG-IP), ID 525232-6 (Enterprise Manager), and ID 528817-6 (BIG-IQ) to this vulnerability, and has evaluated the currently supported releases for potential vulnerability. Additionally, BIG-IP iHealth may list Heuristic H530561 on the Diagnostics > Identified > Medium screen.

To determine if your release is known to be vulnerable, the components or features that are affected by the vulnerability, and for information about releases or hotfixes that address the vulnerability, refer to the following table:

Product| Versions known to be vulnerable| Versions known to be not vulnerable| Severity| Vulnerable component or feature
---|---|---|---|---
BIG-IP LTM| 11.0.0 - 11.6.0
10.1.0 - 10.2.4| 12.0.0
11.6.1
11.5.4| Medium| PHP framework, Control Plane
BIG-IP AAM| 11.4.0 - 11.6.0| 12.0.0
11.6.1
11.5.4| Medium| PHP framework, Control Plane
BIG-IP AFM| 11.3.0 - 11.6.0| 12.0.0
11.6.1
11.5.4| Medium| PHP framework, Control Plane
BIG-IP Analytics| 11.0.0 - 11.6.0| 12.0.0
11.6.1
11.5.4| Medium| PHP framework, Control Plane
BIG-IP APM| 11.0.0 - 11.6.0
10.1.0 - 10.2.4| 12.0.0
11.6.1
11.5.4| Medium| PHP framework, Control Plane
BIG-IP ASM| 11.0.0 - 11.6.0
10.1.0 - 10.2.4| 12.0.0
11.6.1
11.5.4| Medium| PHP framework, Control Plane
BIG-IP DNS| None| 12.0.0| Not vulnerable| None
BIG-IP Edge Gateway| 11.0.0 - 11.3.0
10.1.0 - 10.2.4| None| Medium| PHP framework, Control Plane
BIG-IP GTM| 11.0.0 - 11.6.0
10.1.0 - 10.2.4| 11.6.1
11.5.4| Medium| PHP framework, Control Plane
BIG-IP Link Controller| 11.0.0 - 11.6.0
10.1.0 - 10.2.4| 12.0.0
11.6.1
11.5.4| Medium| PHP framework, Control Plane
BIG-IP PEM| 11.3.0 - 11.6.0| 12.0.0
11.6.1
11.5.4| Medium| PHP framework, Control Plane
BIG-IP PSM| 11.0.0 - 11.4.1
10.1.0 - 10.2.4| None| Medium| PHP framework, Control Plane
BIG-IP WebAccelerator| 11.0.0 - 11.3.0
10.1.0 - 10.2.4| None| Medium| PHP framework, Control Plane
BIG-IP WOM| 11.0.0 - 11.3.0
10.1.0 - 10.2.4| None| Medium| PHP framework, Control Plane
ARX| None| 6.0.0 - 6.4.0| Not vulnerable| None
Enterprise Manager| 3.0.0 - 3.1.1| None| Medium| PHP framework, Control Plane
FirePass| None| 7.0.0
6.0.0 - 6.1.0| Not vulnerable| None
BIG-IQ Cloud| 4.0.0 - 4.5.0| None| Low| PHP framework, Control Plane
BIG-IQ Device| 4.2.0 - 4.5.0| None| Low| PHP framework, Control Plane
BIG-IQ Security| 4.0.0 - 4.5.0| None| Low| PHP framework, Control Plane
BIG-IQ ADC| 4.5.0| None| Low| PHP framework, Control Plane
LineRate| None| 2.5.0 - 2.6.0| Not vulnerable| None
F5 WebSafe| None| 1.0.0| Not vulnerable| None
Traffix SDC| None| 4.0.0 - 4.4.0
3.3.2 - 3.5.1| Not vulnerable| None

If you are running a version listed in the Versions known to be vulnerable column, you can eliminate this vulnerability by upgrading to a version listed in the Versions known to be not vulnerable column. If the table lists only an older version than what you are currently running, or does not list a non-vulnerable version, then no upgrade candidate currently exists.

F5 responds to vulnerabilities in accordance with the Severity values published in the previous table. The Severity values and other security vulnerability parameters are defined in K4602: Overview of the F5 security vulnerability response policy.

To mitigate this vulnerability, F5 recommends that you expose management access only on trusted networks.