logo
DATABASE RESOURCES PRICING ABOUT US

Apache HTTP server vulnerability CVE-2021-44224

Description

A crafted URI sent to httpd configured as a forward proxy (ProxyRequests on) can cause a crash (NULL pointer dereference) or, for configurations mixing forward and reverse proxy declarations, can allow for requests to be directed to a declared Unix Domain Socket endpoint (Server Side Request Forgery). This issue affects Apache HTTP Server 2.4.7 up to 2.4.51 (included). ([CVE-2021-44224](<https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-44224>)) Impact This can allow for requests to be directed to a declared Unix Domain Socket endpoint (Server Side Request Forgery). In the worst case, this could cause a denial of service or compromise to confidentiality of data. For products with **None **in the **Versions known to be vulnerable** column, there is no impact.


Affected Software


CPE Name Name Version
traffix sdc 5.2.0

Related